Skip to content

Original Article Approach towards qualification of TCP/IP network components of PFBR

Prototype Fast Breeder Reactor

bruno

Published July 09, 2026

Original author: Aditya Gour, Tom Mathews, R.P. Behera ยท IndiaOriginal source (new tab)

Original Article Approach towards qualification of TCP/IP network components of PFBR

Project description

๐Ÿ“Œ Overview

https://doi.org/10.1016/j.net.2022.06.015

์ด ํ”„๋กœ์ ํŠธ๋Š” ์ธ๋„ Kalpakkam์— ๊ฑด์„ค ์ค‘์ธ 500 MWe ์›ํ˜• ๊ณ ์†์ฆ์‹๋กœ(PFBR, Prototype Fast Breeder Reactor)์˜ ๋ถ„์‚ฐ ๋””์ง€ํ„ธ ์ œ์–ด ์‹œ์Šคํ…œ(DDCS)์— ์‚ฌ์šฉ๋˜๋Š” TCP/IP ๋„คํŠธ์›Œํฌ ๊ตฌ์„ฑ์š”์†Œ๋ฅผ ๊ฒ€์ฆ(qualification)ํ•˜๋ ค๋Š” ์‚ฌ๋ก€์ž…๋‹ˆ๋‹ค. ์ถœ๋ฐœ์ ์€ ์›์ž๋ ฅ ์•ˆ์ „ ๊ทœ์ œ ์š”๊ฑด์ด์—ˆ๊ณ , ์ดํ›„ ์ƒ์šฉ(commercially available) ๋„คํŠธ์›Œํฌ ๊ตฌ์„ฑ์š”์†Œ๊ฐ€ ์•ˆ์ „ ๊ด€๋ จ(safety-related) ์‹œ์Šคํ…œ์— ์ ํ•ฉํ•œ์ง€๋ฅผ ์ฆ๋ช…ํ•˜๋Š” suitability analysis ๋ฐฉ๋ฒ•๋ก ์œผ๋กœ ํ™•์žฅ๋˜์—ˆ์Šต๋‹ˆ๋‹ค.

ํ•ด๊ฒฐํ•˜๋ ค๋Š” ๋ฌธ์ œ๋Š” ๋ช…ํ™•ํ•ฉ๋‹ˆ๋‹ค. ์›์ž๋ ฅ ๋ฐœ์ „์†Œ์˜ ์ œ์–ด ์‹œ์Šคํ…œ์€ ์•ˆ์ „, ๋ณด์•ˆ, ์‹ ๋ขฐ์„ฑ, ๊ฒฐํ•จ ํ—ˆ์šฉ(fault tolerance)์ด ๊ทœ์ œ ๊ธฐ๊ด€(AERB) ์ง€์นจ์— ๋”ฐ๋ผ ๋ณด์žฅ๋˜์–ด์•ผ ํ•ฉ๋‹ˆ๋‹ค. ๊ทธ๋Ÿฌ๋‚˜ ์Šค์œ„์น˜, ์„œ๋ฒ„/๋””์Šคํ”Œ๋ ˆ์ด ์Šคํ…Œ์ด์…˜, ์ œ์–ด ๋…ธ๋“œ์˜ TCP/IP ๋ชจ๋“ˆ ๊ฐ™์€ ์š”์†Œ๋Š” ์ƒ์šฉ ์ œํ’ˆ์ด๋ฏ€๋กœ, ๊ทœ์ œ ์Šน์ธ์„ ๋ฐ›๊ธฐ ์œ„ํ•ด์„œ๋Š” ๋ณ„๋„์˜ ์ ํ•ฉ์„ฑ ๋ถ„์„์ด ํ•„์š”ํ•ฉ๋‹ˆ๋‹ค. ์ด ๋…ผ๋ฌธ์€ ๊ทธ ๊ฒ€์ฆ ์ ‘๊ทผ๋ฒ•์„ ์ œ์‹œํ•ฉ๋‹ˆ๋‹ค.

๐Ÿ“Œ Features

๋ถ„์‚ฐ ๋””์ง€ํ„ธ ์ œ์–ด ์‹œ์Šคํ…œ(DDCS) 3๊ณ„์ธต ๊ตฌ์กฐ

์ด ํ”„๋กœ์ ํŠธ๋Š” ์ œ์–ด ๋…ธ๋“œ(bottom tier), ํ”„๋กœ์„ธ์Šค ์ปดํ“จํ„ฐ/์„œ๋ฒ„(middle tier), ๋””์Šคํ”Œ๋ ˆ์ด ์Šคํ…Œ์ด์…˜(top tier)์œผ๋กœ ๊ตฌ์„ฑ๋œ 3-tier ์•„ํ‚คํ…์ฒ˜๋ฅผ ๋‹ค๋ฃน๋‹ˆ๋‹ค. ์ง€๋ฆฌ์ ์œผ๋กœ ๋ถ„์‚ฐ๋œ ์ œ์–ด ์‹œ์Šคํ…œ์ด switched Ethernet ๋„คํŠธ์›Œํฌ๋ฅผ ํ†ตํ•ด ์ค‘์•™ ์„œ๋ฒ„ ๋ฐ ๋””์Šคํ”Œ๋ ˆ์ด ์Šคํ…Œ์ด์…˜๊ณผ ์—ฐ๊ฒฐ๋˜๋ฉฐ, TCP ํ”„๋กœํ† ์ฝœ์ด ์‹ ๋ขฐ์„ฑ ์žˆ๋Š” connection-oriented ํ†ต์‹ ์„ ๋ณด์žฅํ•ฉ๋‹ˆ๋‹ค.

Original Article Approach towards qualification of TCP/IP network components of PFBR, ๐Ÿ“Œ Features
Original Article Approach towards qualification of TCP/IP network components of PFBR, ๐Ÿ“Œ Features

Fail-safe ํ†ต์‹  ๊ฒ€์ฆ

์ œ์–ด ๋…ธ๋“œ๋Š” RFC-791(IP), RFC-792(ICMP), RFC-793(TCP), IEEE802.3(EMAC)์„ ์ค€์ˆ˜ํ•ฉ๋‹ˆ๋‹ค. ๋ฐ์ดํ„ฐ ๋˜๋Š” acknowledgment ํŒจํ‚ท์ด 3ํšŒ ๋„๋‹ฌํ•˜์ง€ ์•Š์œผ๋ฉด ๋งํฌ๊ฐ€ unhealthy๋กœ ์„ ์–ธ๋˜๊ณ  fail-safe ๋™์ž‘์ด ๊ฐœ์‹œ๋ฉ๋‹ˆ๋‹ค. ๋…ผ๋ฌธ์€ ์ด ๋™์ž‘์„ ๋‹ค์–‘ํ•œ ์žฅ์•  ์กฐ๊ฑด์—์„œ ๊ฒ€์ฆํ•ฉ๋‹ˆ๋‹ค.

๋„คํŠธ์›Œํฌ ์ž„ํŽ˜์–ด๋จผํŠธ(impairment) ํ…Œ์ŠคํŠธ

ํŒจํ‚ท ์†์ƒ(corruption), ์†์‹ค(drop), ์ง€์—ฐ(delay), ์ˆœ์„œ ๋’ค๋ฐ”๋€œ(out-of-order), ์ค‘๋ณต(duplicate), ๋ฒ„์ŠคํŠธ(burst) ๋„์ฐฉ ๋“ฑ ์‹ค์ œ ํ˜„์žฅ์—์„œ ๋ฐœ์ƒ ๊ฐ€๋Šฅํ•œ ์žฅ์• ๋ฅผ network impairment tool๋กœ ์ฃผ์ž…ํ•˜๊ณ  ๋งํฌ ๊ฑฐ๋™์„ ๋ถ„์„ํ•ฉ๋‹ˆ๋‹ค.

์Šค์œ„์น˜ ๋ฒค์น˜๋งˆํ‚น๊ณผ ๋ณด์•ˆ ๊ธฐ๋Šฅ ๊ฒ€์ฆ

RFC-2544 ๋ฐฉ๋ฒ•๋ก ์— ๋”ฐ๋ผ layer-2/3 ์Šค์œ„์น˜์˜ routing latency, throughput, frame loss๋ฅผ ๋ฒค์น˜๋งˆํฌํ•ฉ๋‹ˆ๋‹ค. ๋˜ํ•œ rate limiting, MAC/IP binding, port disabling, multicast limiting, DoS ๊ณต๊ฒฉ ๋Œ€์‘ ๊ฐ™์€ ๋ณด์•ˆ ๊ธฐ๋Šฅ๋„ ๊ฒ€์ฆํ•ฉ๋‹ˆ๋‹ค.

๋„คํŠธ์›Œํฌ ์ง€์—ฐ(latency) ํŠน์„ฑํ™”

์šด์˜์ž๊ฐ€ ๋งˆ์šฐ์Šค๋ฅผ ํด๋ฆญํ•œ ์‹œ์ ๋ถ€ํ„ฐ CPU๊ฐ€ ๋ช…๋ น์„ ์ฒ˜๋ฆฌํ•˜๋Š” ์‹œ์ ๊นŒ์ง€์˜ ์‹ค์ œ ์‘๋‹ต ์‹œ๊ฐ„์„ ์ธก์ •ํ•˜์—ฌ, ์—ฐ๋ฃŒ ์ทจ๊ธ‰ ๋ฐ ์ œ์–ดยท์•ˆ์ „๋ด‰ ๊ตฌ๋™ ์‹œ์Šคํ…œ์˜ 200 ms ์š”๊ฑด์„ ์ถฉ์กฑํ•˜๋Š”์ง€ ํ™•์ธํ•ฉ๋‹ˆ๋‹ค. ํ‰๊ท  27.2 ms์˜ ์‘๋‹ต ์‹œ๊ฐ„์ด ๊ด€์ธก๋˜์—ˆ์Šต๋‹ˆ๋‹ค.

๐Ÿ“Œ Developer

์ด ๋…ผ๋ฌธ์€ ์ธ๋„ IGCAR(Indira Gandhi Centre for Atomic Research)์˜ Aditya Gour, Tom Mathews, R.P. Behera๊ฐ€ ์ˆ˜ํ–‰ํ•œ ์—ฐ๊ตฌ์ž…๋‹ˆ๋‹ค. ์ €์ž๋“ค์€ PFBR์˜ ์‹ค์‹œ๊ฐ„ fault-tolerant ์ปดํ“จํ„ฐ ๊ธฐ๋ฐ˜ ์ œ์–ด ์‹œ์Šคํ…œ(RTC)๊ณผ ๋„คํŠธ์›Œํฌ ๊ตฌ์„ฑ์š”์†Œ ์„ค๊ณ„ยท๊ฒ€์ฆ ๊ฒฝํ—˜์„ ๋ฐ”ํƒ•์œผ๋กœ ์ด ๋ฐฉ๋ฒ•๋ก ์„ ์ •๋ฆฝํ–ˆ์Šต๋‹ˆ๋‹ค.

์ด ๋ฐฐ๊ฒฝ์€ ํ”„๋กœ์ ํŠธ ๊ตฌ์กฐ์—์„œ๋„ ํ™•์ธ๋ฉ๋‹ˆ๋‹ค. ์› ๋…ผ๋ฌธ์€ ๋‹จ์ˆœ ๋„คํŠธ์›Œํฌ ํ…Œ์ŠคํŠธ๊ฐ€ ์•„๋‹ˆ๋ผ ์ œ์–ด ๋…ธ๋“œ์šฉ ์ง„๋‹จ(diagnostics) ํŽŒ์›จ์–ด, ์„œ๋ฒ„/๋””์Šคํ”Œ๋ ˆ์ด ์Šคํ…Œ์ด์…˜์šฉ GUI ์†Œํ”„ํŠธ์›จ์–ด ์„ค๊ณ„๋ถ€ํ„ฐ ์Šค์œ„์น˜ ๋ฒค์น˜๋งˆํ‚น, ๋ณด์•ˆ ๊ฒ€์ฆ, ์ง€์—ฐ ์ธก์ •๊นŒ์ง€ ํฌํ•จํ•˜๋Š” ์ข…ํ•ฉ์ ์ธ qualification ํ”„๋ ˆ์ž„์›Œํฌ๋ฅผ ์ œ์‹œํ•ฉ๋‹ˆ๋‹ค. ์ด ์—ฐ๊ตฌ๋Š” Nuclear Engineering and Technology ์ €๋„(Volume 54, Issue 11, 2022)์— Creative Commons ๋ผ์ด์„ ์Šค open access๋กœ ๊ฒŒ์žฌ๋˜์—ˆ์Šต๋‹ˆ๋‹ค.

๐Ÿ“Œ System Architecture

๐Ÿ“Œ System Architecture

์ด ํ”„๋กœ์ ํŠธ์˜ ๊ตฌ์กฐ๋Š” ํฌ๊ฒŒ ๋‘ ๊ณ„์ธต์œผ๋กœ ๋‚˜๋ˆŒ ์ˆ˜ ์žˆ์Šต๋‹ˆ๋‹ค.

์ฒซ ๋ฒˆ์งธ๋Š” field control path์ž…๋‹ˆ๋‹ค.

 
Field Sensors / Actuators
        โ†“ GPIO / I/O
RTC / RTU Control Node (VME bus, dual redundant)
        โ†“ Dual TCP/IP Offload Module (WIZnet)
Switched Ethernet

๋‘ ๋ฒˆ์งธ๋Š” network/service path์ž…๋‹ˆ๋‹ค.

 
RTC Control Node
        โ†“ TCP/IP over Ethernet
Layer-2 / Layer-3 Switch (triplicated LAN)
        โ†“ Switched Network
Central Server (Process Computer) / Display Station (MCR GUI)

Field control path๋Š” ์„ผ์„œยท์•ก์ถ”์—์ดํ„ฐ๋ฅผ ์ œ์–ดํ•˜๋Š” ์‹ค์‹œ๊ฐ„ ๊ฒฝ๋กœ์ž…๋‹ˆ๋‹ค. ๋ฐ˜๋ฉด network/service path๋Š” ์ œ์–ด ๋…ธ๋“œ์™€ ์ค‘์•™ ์„œ๋ฒ„/๋””์Šคํ”Œ๋ ˆ์ด ์Šคํ…Œ์ด์…˜ ๊ฐ„ ๋ฐ์ดํ„ฐ ํ†ต์‹ ์„ ๋‹ด๋‹นํ•ฉ๋‹ˆ๋‹ค. ์ด ๋ถ„๋ฆฌ๊ฐ€ ์ค‘์š”ํ•ฉ๋‹ˆ๋‹ค. ์ •์ƒ ์กฐ๊ฑด์—์„œ๋Š” ์ฃผ ์ œ์–ด์‹ค(MCR)์—์„œ ์ „์ฒด ํ”Œ๋žœํŠธ๋ฅผ ์ œ์–ดํ•˜์ง€๋งŒ, ๋„คํŠธ์›Œํฌ ์†์‹ค์ด๋‚˜ ์ง„๋‹จ ์‹คํŒจ ๊ฐ™์€ ์žฅ์•  ์กฐ๊ฑด์—์„œ๋Š” RTC ์‹œ์Šคํ…œ์ด ํ•ญ์ƒ fail-safe ์ถœ๋ ฅ์„ ๋ณด์žฅํ•˜์—ฌ ํ”Œ๋žœํŠธ ์•ˆ์ „์„ ์œ ์ง€ํ•ฉ๋‹ˆ๋‹ค.

๐Ÿ“Œ Role and Application of the WIZnet's Chip

๐Ÿ“Œ Role and Application of the WIZnet's Chip

์ด ํ”„๋กœ์ ํŠธ์—์„œ ํ™•์ธ๋˜๋Š” WIZnet chip์€ W3150A+ ๋ฐ NM7010B+ TCP/IP offload module์ž…๋‹ˆ๋‹ค. ์ด ๋ชจ๋“ˆ๋“ค์€ hardwired TCP/IP stack์„ ๋‚ด์žฅํ•œ ๋„คํŠธ์›Œํฌ ํ”„๋กœ์„ธ์„œ๋ฅผ ์‚ฌ์šฉํ•˜๋ฉฐ, RTC ์ œ์–ด ๋…ธ๋“œ์˜ CPU์™€ ์—ฐ๊ฒฐ๋˜์–ด ์ด๋”๋„ท ํ†ต์‹ ์„ ์ฒ˜๋ฆฌํ•ฉ๋‹ˆ๋‹ค. ๋…ผ๋ฌธ์— ๋”ฐ๋ฅด๋ฉด PFBR์—๋Š” ์•ฝ 1,300๊ฐœ์˜ WIZnet ๋ชจ๋“ˆ์ด dual redundant ๊ตฌ์„ฑ์œผ๋กœ ์‚ฌ์šฉ๋ฉ๋‹ˆ๋‹ค.

๐Ÿ“Œ Role and Application of the WIZnet's Chip

์ด ํ”„๋กœ์ ํŠธ์—์„œ WIZnet ๋ชจ๋“ˆ์˜ ์—ญํ• ์€ ๋ช…ํ™•ํ•ฉ๋‹ˆ๋‹ค. Hardwired TCP/IP stack์„ ํ†ตํ•ด ์ž„๋ฒ ๋””๋“œ ์‹œ์Šคํ…œ ์†Œํ”„ํŠธ์›จ์–ด ์•„ํ‚คํ…์ฒ˜๋ฅผ ๋‹จ์ˆœํ•˜๊ณ (simple), ๊ฒฐ์ •๋ก ์ ์ด๋ฉฐ(deterministic), ์‹ค์‹œ๊ฐ„ ์„ฑ๋Šฅ์„ ๋ณด์žฅํ•  ๋งŒํผ ๋†’์€ ์‹ ๋ขฐ์„ฑ(highly reliable)์œผ๋กœ ๋งŒ๋“œ๋Š” ๊ฒƒ์ž…๋‹ˆ๋‹ค. ๊ฐ CPU ์นด๋“œ๋Š” ๋‘ ๊ฐœ์˜ ๋„คํŠธ์›Œํฌ ๋ชจ๋“ˆ์„ ๊ฐ€์ง€๋ฉฐ, ๋ชจ๋“ˆ๋‹น 4๊ฐœ์˜ ์†Œ์ผ“์„ ์‚ฌ์šฉํ•ฉ๋‹ˆ๋‹ค.

์ด ์ฐจ์ด๊ฐ€ ์ค‘์š”ํ•ฉ๋‹ˆ๋‹ค. ์›์ž๋ ฅ ์•ˆ์ „ ๊ด€๋ จ ์ œ์–ด ์‹œ์Šคํ…œ์€ ์ผ๋ฐ˜ ํ†ต์‹  ์‹œ์Šคํ…œ๊ณผ ๋‹ค๋ฆ…๋‹ˆ๋‹ค. TCP retry ๊ฐ’(3ํšŒ)๊ณผ timeout(140 ms)์ด ๋ชจ๋“ˆ ํ†ต์‹ ์— ์„ค์ •๋˜์–ด ์žˆ์–ด, ์†์ƒยท์†์‹คยท์ง€์—ฐ ํŒจํ‚ท ์ƒํ™ฉ์—์„œ๋„ ์˜ˆ์ธก ๊ฐ€๋Šฅํ•œ fail-safe ๊ฑฐ๋™์„ ๋ณด์žฅํ•ฉ๋‹ˆ๋‹ค. ๋…ผ๋ฌธ ๊ฒ€์ฆ ๊ฒฐ๊ณผ, WIZnet ๋ชจ๋“ˆ์€ 165์‹œ๊ฐ„ burn-in ํ…Œ์ŠคํŠธ์—์„œ zero packet drop๊ณผ zero malformed packet์„ ๊ธฐ๋กํ–ˆ์Šต๋‹ˆ๋‹ค.

๊ด€์ WIZnet ๋ชจ๋“ˆ ์ ์šฉ ๊ฐ€์น˜
๊ฒฐ์ •๋ก ์„ฑHardwired TCP/IP stack์œผ๋กœ real-time ์„ฑ๋Šฅ ๋ณด์žฅ
์‹ ๋ขฐ์„ฑ165์‹œ๊ฐ„ ์—ฐ์† ํ…Œ์ŠคํŠธ์—์„œ zero packet drop, zero malformed packet
ํ‘œ์ค€ ์ค€์ˆ˜RFC-791/792/793, IEEE802.3 compliance ๊ฒ€์ฆ ์™„๋ฃŒ
์•ˆ์ „ ์„ค๊ณ„TCP retry(3)ยทtimeout(140 ms) ๊ธฐ๋ฐ˜์˜ ์˜ˆ์ธก ๊ฐ€๋Šฅํ•œ fail-safe ๊ฑฐ๋™
๊ทœ๋ชจ ํ™•์žฅ์„ฑ์•ฝ 1,300๊ฐœ ๋ชจ๋“ˆ์ด dual redundant๋กœ ์•ˆ์ • ์šด์šฉ

๐Ÿ“Œ Related Existing Contents & Expansion Value

WIZnet Hardwired TCP/IP Chip (W5500 / W3150A+)

Similarity Point:
๋…ผ๋ฌธ์ด ์‚ฌ์šฉํ•˜๋Š” W3150A+์™€ NM7010B+๋Š” WIZnet์˜ hardwired TCP/IP offload ๊ณ„์—ด๋กœ, W5500 ๋“ฑ ํ›„์† ์ œํ’ˆ๊ณผ ๋™์ผํ•œ ์„ค๊ณ„ ์ฒ ํ•™(hardwired stack, SPI/๋ฒ„์Šค ์—ฐ๊ฒฐ, ๋…๋ฆฝ ์†Œ์ผ“)์„ ๊ณต์œ ํ•ฉ๋‹ˆ๋‹ค. Fail-safe์™€ ๊ฒฐ์ •๋ก ์  ํ†ต์‹ ์ด ํ•„์š”ํ•œ ์ž„๋ฒ ๋””๋“œ ์ œ์–ด use case์—์„œ ์ง์ ‘ ์—ฐ๊ฒฐ๋ฉ๋‹ˆ๋‹ค.

Difference:
์ผ๋ฐ˜ maker ํ”„๋กœ์ ํŠธ๊ฐ€ ์Šค๋งˆํŠธํ™ˆยทIoT ํ™˜๊ฒฝ์—์„œ W5500์„ ์‚ฌ์šฉํ•˜๋Š” ๋ฐ˜๋ฉด, ์ด ๋…ผ๋ฌธ์€ ์›์ž๋ ฅ ์•ˆ์ „ ๊ด€๋ จ ์‹œ์Šคํ…œ์ด๋ผ๋Š” ๊ทนํ•œ์˜ ์‹ ๋ขฐ์„ฑยท๊ทœ์ œ ์š”๊ฑด ํ™˜๊ฒฝ์—์„œ WIZnet ๋ชจ๋“ˆ์„ ๊ฒ€์ฆํ•ฉ๋‹ˆ๋‹ค.

Connection Value:
๋‘ ๊ด€์ ์„ ํ•จ๊ป˜ ๋ณด๋ฉด WIZnet์˜ hardwired TCP/IP ์ ‘๊ทผ๋ฒ•์ด ์ทจ๋ฏธ์šฉ IoT๋ถ€ํ„ฐ ์›์ž๋ ฅ ์ œ์–ด๊นŒ์ง€ ํ™•์žฅ ๊ฐ€๋Šฅํ•œ network foundation์ž„์„ ์„ค๋ช…ํ•  ์ˆ˜ ์žˆ์Šต๋‹ˆ๋‹ค.

๐Ÿ“Œ Market & Application Value

์ด ํ”„๋กœ์ ํŠธ๊ฐ€ ์ ์šฉ๋  ์ˆ˜ ์žˆ๋Š” ๋ถ„์•ผ๋Š” ์›์ž๋ ฅ ๋ฐœ์ „์†Œ I&C, ๋ฐœ์ „ ํ”Œ๋žœํŠธ ์ œ์–ด, ์‚ฐ์—…์šฉ ์•ˆ์ „ ๊ณ„์žฅ ์‹œ์Šคํ…œ(SIS), ํ”„๋กœ์„ธ์Šค ์ž๋™ํ™”, ๊ทธ๋ฆฌ๊ณ  ๊ฒฐํ•จ ํ—ˆ์šฉ์ด ์š”๊ตฌ๋˜๋Š” ์‹ค์‹œ๊ฐ„ ๋ถ„์‚ฐ ์ œ์–ด ์‹œ์Šคํ…œ ๋“ฑ์ž…๋‹ˆ๋‹ค.

B2C ๊ด€์ ๋ณด๋‹ค๋Š” B2B/์‚ฐ์—… ๊ด€์ ์—์„œ ์˜๋ฏธ๊ฐ€ ํฝ๋‹ˆ๋‹ค. ์•ˆ์ „ critical ์ œ์–ด ์‹œ์Šคํ…œ์€ ๊ทœ์ œ ์Šน์ธ, ๊ฒฐํ•จ ํ—ˆ์šฉ, ์žฅ๊ธฐ ์‹ ๋ขฐ์„ฑ์ด ํ•ต์‹ฌ์ด๋ฉฐ, ์ด ์ง€์ ์—์„œ hardwired TCP/IP stack์„ ๋‚ด์žฅํ•œ WIZnet ๋ชจ๋“ˆ์€ ์„ค๊ณ„์ƒ ์„ค๋“๋ ฅ์ด ์žˆ์Šต๋‹ˆ๋‹ค.

๊ธฐ์กด ์†Œํ”„ํŠธ์›จ์–ด TCP/IP stack๊ณผ ๋น„๊ตํ–ˆ์„ ๋•Œ, ์ด ํ”„๋กœ์ ํŠธ์˜ ์ฐจ๋ณ„์ ์€ โ€œ๊ฒฐ์ •๋ก ์ ์ด๊ณ  ๊ฒ€์ฆ ๊ฐ€๋Šฅํ•œ ํ•˜๋“œ์›จ์–ด ๊ธฐ๋ฐ˜ ํ†ต์‹ โ€์— ์žˆ์Šต๋‹ˆ๋‹ค. ์†Œํ”„ํŠธ์›จ์–ด stack์€ OS ์Šค์ผ€์ค„๋ง์— ๋”ฐ๋ผ ์ง€์—ฐ์ด ๋ณ€๋™๋  ์ˆ˜ ์žˆ์ง€๋งŒ, hardwired stack์€ ์˜ˆ์ธก ๊ฐ€๋Šฅํ•œ ๊ฑฐ๋™์„ ์ œ๊ณตํ•˜์—ฌ ์•ˆ์ „ ์‹œ์Šคํ…œ์˜ qualification์„ ๋‹จ์ˆœํ™”ํ•ฉ๋‹ˆ๋‹ค.

๐Ÿ“Œ External Indicators

ํ•ญ๋ชฉํ™•์ธ ๊ฒฐ๊ณผํ•ด์„์ถœ์ฒ˜
์ €๋„ ๊ฒŒ์žฌNuclear Engineering and Technology, Vol.54, Issue 11 (2022), pp.3975-3984Peer-reviewed ์ €๋„์— open access๋กœ ๊ฒŒ์žฌ๋œ ์‹ ๋ขฐ์„ฑ ์žˆ๋Š” ์ž๋ฃŒScienceDirect
์ธ์šฉ ์‹ค์ Cited by 2 (2025๋…„ ๊ธฐ์ค€, Nuclear Technology / IEEE Sensors Journal)ํ›„์† ์—ฐ๊ตฌ์— ์ฐธ์กฐ๋˜๋Š” ๋ฐฉ๋ฒ•๋ก ์  ๊ฐ€์น˜ ํ™•์ธScienceDirect
๊ฒ€์ฆ ๊ทœ๋ชจ์•ฝ 1,300๊ฐœ WIZnet ๋ชจ๋“ˆ, 165์‹œ๊ฐ„ burn-in ํ…Œ์ŠคํŠธ์‹ค์ œ ์›์ž๋กœ ๊ทœ๋ชจ์˜ ๋Œ€๋Ÿ‰ ์ ์šฉ ๋ฐ ์žฅ๊ธฐ ๊ฒ€์ฆ๋…ผ๋ฌธ ๋ณธ๋ฌธ

๐Ÿ“Œ WIZnet Strategic Value

์ด ํ”„๋กœ์ ํŠธ์˜ ํ•ต์‹ฌ ๊ฐ€์น˜๋Š” WIZnet์˜ hardwired TCP/IP offload module์ด ์›์ž๋ ฅ ์•ˆ์ „ ๊ด€๋ จ ์‹ค์‹œ๊ฐ„ ์ œ์–ด ์‹œ์Šคํ…œ์˜ ํ†ต์‹  backbone์œผ๋กœ ๊ฒ€์ฆ๋˜์—ˆ๋‹ค๋Š” ์ ์ž…๋‹ˆ๋‹ค. WIZnet ๋ชจ๋“ˆ์€ ์ด ๊ตฌ์กฐ์—์„œ ๋‹จ์ˆœ ๋„คํŠธ์›Œํฌ add-on์ด ์•„๋‹ˆ๋ผ, ๊ฒฐ์ •๋ก ์ ์ด๊ณ  fail-safeํ•œ ํ†ต์‹ ์„ ๋ณด์žฅํ•˜๋Š” ํ•ต์‹ฌ ์š”์†Œ์ž…๋‹ˆ๋‹ค.

์™ธ๋ถ€ ๊ฐœ๋ฐœ์ž์—๊ฒŒ ์ฃผ๋Š” ๋ฉ”์‹œ์ง€๋„ ๋ช…ํ™•ํ•ฉ๋‹ˆ๋‹ค.

  • Hardwired TCP/IP stack์€ ๊ฒฐ์ •๋ก ์  real-time ํ†ต์‹ ์„ ์ œ๊ณตํ•˜๊ณ ,
  • RFC/IEEE ํ‘œ์ค€ ์ค€์ˆ˜๋กœ ๊ทœ์ œ qualification์„ ๋‹จ์ˆœํ™”ํ•˜๋ฉฐ,
  • Dual redundant ๊ตฌ์„ฑ์œผ๋กœ fault tolerance๋ฅผ ํ™•๋ณดํ•œ๋‹ค.

์ด ์กฐํ•ฉ์€ ์ผ๋ฐ˜์ ์ธ ์†Œํ”„ํŠธ์›จ์–ด stack ๊ธฐ๋ฐ˜ ํ†ต์‹ ๋ณด๋‹ค ์•ˆ์ „ critical ํ™˜๊ฒฝ์—์„œ ์„ค๋“๋ ฅ์ด ํฝ๋‹ˆ๋‹ค. ์›์ž๋ ฅ ์ œ์–ด ๋…ธ๋“œ๋Š” ์žฅ๊ธฐ๊ฐ„ ๋ฌด์ค‘๋‹จ ์šด์šฉ๋˜์–ด์•ผ ํ•˜๊ณ , ํ†ต์‹  ์žฅ์• ๊ฐ€ ๊ณง ์•ˆ์ „ ๋ฌธ์ œ๋กœ ์ด์–ด์งˆ ์ˆ˜ ์žˆ์Šต๋‹ˆ๋‹ค. ๋”ฐ๋ผ์„œ hardwired TCP/IP ๊ธฐ๋ฐ˜์˜ ์˜ˆ์ธก ๊ฐ€๋Šฅํ•œ ๊ฑฐ๋™์€ ์‹ค์ œ ์ œํ’ˆยท์‹œ์Šคํ…œ ๊ธฐํš ๋‹จ๊ณ„์—์„œ ์ค‘์š”ํ•œ ์„ค๊ณ„ ์š”์†Œ๊ฐ€ ๋ฉ๋‹ˆ๋‹ค.

๐Ÿ“Œ Summary

์ด ํ”„๋กœ์ ํŠธ๋Š” ์ธ๋„ PFBR ์›์ž๋กœ์˜ ๋ถ„์‚ฐ ๋””์ง€ํ„ธ ์ œ์–ด ์‹œ์Šคํ…œ(DDCS)์— ์‚ฌ์šฉ๋˜๋Š” TCP/IP ๋„คํŠธ์›Œํฌ ๊ตฌ์„ฑ์š”์†Œ โ€” ์ œ์–ด ๋…ธ๋“œ์˜ WIZnet TCP/IP offload module, layer-2/3 ์Šค์œ„์น˜, ์„œ๋ฒ„/๋””์Šคํ”Œ๋ ˆ์ด ์Šคํ…Œ์ด์…˜ โ€” ๋ฅผ ๊ฒ€์ฆํ•˜๋Š” ์ข…ํ•ฉ์ ์ธ suitability analysis ๋ฐฉ๋ฒ•๋ก ์„ ์ œ์‹œํ•ฉ๋‹ˆ๋‹ค.

๊ฐ€์žฅ ์ค‘์š”ํ•œ WIZnet ๊ด€์ ์˜ ๊ฐ€์น˜๋Š” hardwired TCP/IP stack์„ ๋‚ด์žฅํ•œ WIZnet ๋ชจ๋“ˆ์ด ์›์ž๋ ฅ ์•ˆ์ „ ์‹œ์Šคํ…œ์˜ ๊ทนํ•œ ์‹ ๋ขฐ์„ฑ ์š”๊ฑด์„ ์ถฉ์กฑํ•˜๋ฉฐ ๊ฒ€์ฆ๋˜์—ˆ๋‹ค๋Š” ์ ์ž…๋‹ˆ๋‹ค. ์•ฝ 1,300๊ฐœ ๋ชจ๋“ˆ์ด dual redundant๋กœ ์‚ฌ์šฉ๋˜์—ˆ๊ณ , 165์‹œ๊ฐ„ ์—ฐ์† ํ…Œ์ŠคํŠธ์—์„œ zero packet drop๊ณผ zero malformed packet์„ ๊ธฐ๋กํ–ˆ์œผ๋ฉฐ, RFC/IEEE ํ‘œ์ค€ ์ค€์ˆ˜๋„ ํ™•์ธ๋˜์—ˆ์Šต๋‹ˆ๋‹ค.

์ด ํ”„๋กœ์ ํŠธ๋Š” hardwired TCP/IP ์ ‘๊ทผ๋ฒ•์ด ์–ด๋–ป๊ฒŒ ๊ฒฐ์ •๋ก ์ ์ด๊ณ  fail-safeํ•œ ํ†ต์‹ ์„ ์ œ๊ณตํ•˜์—ฌ, ์›์ž๋ ฅ์„ ํฌํ•จํ•œ ์•ˆ์ „ critical ์‹ค์‹œ๊ฐ„ ์ œ์–ด ์‹œ์Šคํ…œ์—์„œ ์‹ ๋ขฐ์„ฑ ์žˆ๊ฒŒ ํ™œ์šฉ๋  ์ˆ˜ ์žˆ๋Š”์ง€๋ฅผ ๋ณด์—ฌ์ฃผ๋Š” ๊ฒ€์ฆ ์‚ฌ๋ก€๋กœ ๋ณด๋Š” ๊ฒƒ์ด ์ ์ ˆํ•ฉ๋‹ˆ๋‹ค.

๐Ÿ“Œ FAQ

1. ์ด ํ”„๋กœ์ ํŠธ๋Š” ์–ด๋–ค ๋ฌธ์ œ๋ฅผ ํ•ด๊ฒฐํ•˜๋ ค๋Š”๊ฐ€?

์ƒ์šฉ ๋„คํŠธ์›Œํฌ ๊ตฌ์„ฑ์š”์†Œ(์Šค์œ„์น˜, ์„œ๋ฒ„, TCP/IP ๋ชจ๋“ˆ)๊ฐ€ ์›์ž๋ ฅ ์•ˆ์ „ ๊ด€๋ จ ์‹œ์Šคํ…œ์— ์ ํ•ฉํ•œ์ง€๋ฅผ ๊ทœ์ œ ๊ธฐ๊ด€ ์Šน์ธ ๊ด€์ ์—์„œ ์ฆ๋ช…ํ•˜๋Š” ๋ฌธ์ œ๋ฅผ ๋‹ค๋ฃน๋‹ˆ๋‹ค. ๋…ผ๋ฌธ์€ ์ด๋ฅผ ์œ„ํ•œ suitability analysis ๋ฐฉ๋ฒ•๋ก ๊ณผ ํ…Œ์ŠคํŠธ ํ”Œ๋žซํผ์„ ์ œ์‹œํ•ฉ๋‹ˆ๋‹ค.

2. WIZnet ๋ชจ๋“ˆ์€ ์ด ํ”„๋กœ์ ํŠธ์—์„œ ์–ด๋–ค ์—ญํ• ์„ ํ•˜๋Š”๊ฐ€?

WIZnet์˜ W3150A+ / NM7010B+ TCP/IP offload module์€ RTC ์ œ์–ด ๋…ธ๋“œ์˜ ์ด๋”๋„ท ํ†ต์‹ ์„ ๋‹ด๋‹นํ•ฉ๋‹ˆ๋‹ค. Hardwired TCP/IP stack์„ ํ†ตํ•ด ๊ฒฐ์ •๋ก ์ ์ด๊ณ  ์‹ ๋ขฐ์„ฑ ๋†’์€ real-time ํ†ต์‹ ์„ ์ œ๊ณตํ•˜๋ฉฐ, ์•ฝ 1,300๊ฐœ๊ฐ€ dual redundant๋กœ ์‚ฌ์šฉ๋ฉ๋‹ˆ๋‹ค.

3. ๊ฒ€์ฆ ๊ฒฐ๊ณผ๋Š” ์–ด๋• ๋Š”๊ฐ€?

165์‹œ๊ฐ„ burn-in ํ…Œ์ŠคํŠธ์—์„œ zero packet drop๊ณผ zero malformed packet์„ ๊ธฐ๋กํ–ˆ๊ณ , ํŒจํ‚ท ์†์ƒยท์†์‹คยท์ง€์—ฐยท์ˆœ์„œ ๋’ค๋ฐ”๋€œ ๋“ฑ ์žฅ์•  ์กฐ๊ฑด์—์„œ ์˜ˆ์ƒ๋Œ€๋กœ fail-safe ๊ฑฐ๋™์„ ๋ณด์˜€์Šต๋‹ˆ๋‹ค. RFC-791/792/793 ๋ฐ IEEE802.3 ํ‘œ์ค€ ์ค€์ˆ˜๋„ ํ™•์ธ๋˜์—ˆ์Šต๋‹ˆ๋‹ค.

4. ๊ฐœ๋ฐœ์ž๊ฐ€ ์ด ํ”„๋กœ์ ํŠธ์—์„œ ์žฌ์‚ฌ์šฉํ•  ์ˆ˜ ์žˆ๋Š” ๋ถ€๋ถ„์€ ๋ฌด์—‡์ธ๊ฐ€?

์ œ์–ด ๋…ธ๋“œ์šฉ ์ง„๋‹จ ํŽŒ์›จ์–ด์™€ GUI ์†Œํ”„ํŠธ์›จ์–ด ์„ค๊ณ„, network impairment ๊ธฐ๋ฐ˜ ํ…Œ์ŠคํŠธ ๋ฐฉ๋ฒ•๋ก , RFC-2544 ์Šค์œ„์น˜ ๋ฒค์น˜๋งˆํ‚น ์ ˆ์ฐจ, ์Šค์œ„์น˜ ๋ณด์•ˆ ๊ธฐ๋Šฅ ๋ฐ DoS ๊ฒ€์ฆ ๋ฐฉ๋ฒ•, ๋„คํŠธ์›Œํฌ ์ง€์—ฐ ์ธก์ • ๋ฐฉ๋ฒ•์„ ์ฐธ๊ณ ํ•  ์ˆ˜ ์žˆ์Šต๋‹ˆ๋‹ค.

5. ์‹ค์ œ ์‘๋‹ต ์‹œ๊ฐ„ ์„ฑ๋Šฅ์€ ์–ด๋А ์ •๋„์ธ๊ฐ€?

์šด์˜์ž ๋งˆ์šฐ์Šค ํด๋ฆญ๋ถ€ํ„ฐ CPU ๋ช…๋ น ์ฒ˜๋ฆฌ๊นŒ์ง€ ํ‰๊ท  27.2 ms๊ฐ€ ์ธก์ •๋˜์–ด, ์—ฐ๋ฃŒ ์ทจ๊ธ‰ ๋ฐ ์ œ์–ดยท์•ˆ์ „๋ด‰ ๊ตฌ๋™ ์‹œ์Šคํ…œ์˜ 200 ms ์š”๊ฑด์„ ์ถฉ๋ถ„ํžˆ ๋งŒ์กฑํ–ˆ์Šต๋‹ˆ๋‹ค.

๐Ÿ“Œ Reference Link

https://www.sciencedirect.com/science/article/pii/S1738573322002972

https://doi.org/10.1016/j.net.2022.06.015

Comments

Comments